Huy137

Here is the problem:

As you can see, with the 3.8.99 update, whenever I creat a keyframe, the program itseft creat a random curve instead of straight line. And I have to manual fixing that line every time I make a new keyframe, every single time.
Huy137
  • Posts: 31

Nate

That shouldn't happen, sorry! Can you please post or email the Spine project file where this happens? contact@esotericsoftware.com We need to see the project file before saving it with 3.8.99.
User avatar
Nate

Nate
  • Posts: 10311

Huy137

Well, here is a video showing this bug. I didn't have the project file before update but I'll prepare the test project for you soon:
Huy137
  • Posts: 31

Søren

Hi, please try checking if your Default graph preset is set to Beziér instead of Linear

To do that, just click Presets in the Graph view, and then select Default. If Default is set to Bezier you can click Linear while having Default selected to revert it back to Linear.

I hope this helps.
User avatar
Søren

Shiu
  • Posts: 2427

Huy137

Thank you, it solve the problem instantly! You may want to including this trick in Graph tutorial for Spine, since a lot of new comer may have the same problem with it.
Huy137
  • Posts: 31

Nate

Oh, good catch @Søren!

In v4 (currently in beta) the graph presets are gone because it is rare to be able to reuse curves. Instead of a default graph preset, the selected (blue) stepped, linear, or Bezier button determines the type of key when creating a new key before the first key or past the last key on a timeline. When creating a key between two existing keys, it always uses the same type of curve as the key before the new key.
User avatar
Nate

Nate
  • Posts: 10311


Return to Editor