RollCaskett

Hi everyone. Having an annoying issue with an asset I have been working on. I created an arcade machine that dispenses coins onto a conveyer belt. It looks great in Spine, the atlas images look good, but when the file is implemented, it looks all blurry / fuzzy. (Show in attached image file.) Not sure what may be going on and if I am doing something wrong on export? Any help is greatly appreciated. :heart:
You do not have the required permissions to view the files attached to this post.
RollCaskett
  • Posts: 12

Harald

Which runtime (or game toolkit) are you using?

If you are using spine-unity and Unity, please post some screenshots of your Texture import settings of the atlas texture. Screenshots of the Material and Shader settings could also be helpful.
User avatar
Harald

Harri
  • Posts: 2170

RollCaskett

Yes. My team is using Spine-Unity. The latest 3.7 version. :)
You do not have the required permissions to view the files attached to this post.
RollCaskett
  • Posts: 12

Harald

Thanks for posting the screenshots. While you should enable sRGB (Color Texture) at the Texture import settings, it will not make your images blurry.

What is the original image size of your atlas texture, as the Max Size is set to 2048?
User avatar
Harald

Harri
  • Posts: 2170

RollCaskett

Ah. Could that be the problem? The original texture is huge actually. 8192 x 8192.
RollCaskett
  • Posts: 12

Harald

Of course. If you let Unity downscale the texture by a factor of 1/4 from 8k to 2k you will obviously end up with a more blurry image.
User avatar
Harald

Harri
  • Posts: 2170


Return to Editor