psantos

How I can i have the same JSON output as version 3.7 on the current spine version? The current version (3.8.59)'s JSON output is not working fine with pixi 4.8. Is there any way i can make it run?
You do not have the required permissions to view the files attached to this post.
psantos
  • Posts: 1

Nate

What version of the Spine Runtimes is Pixi using? You need to export from the same version of the Spine editor. Eg, if Pixi supports 3.8, which I think it does, you need to export from Spine 3.8. If you have many projects, you can use the CLI:
Export - Spine User Guide: Command line
For example:
spine-runtimes/export.sh at 3.8

---

Specifying 3.7.94 should work. Did you make sure to press Save on the settings dialog after setting the version to 3.7.94?
User avatar
Nate

Nate
  • Posts: 9161

badlogic

I assume you are using pixi-spine? Looks like Spine 3.8 and pixi v4.x aren't supported. Ping Ivan on the pixi-spine issue tracker, he's very responsive! https://github.com/pixijs/pixi-spine
User avatar
badlogic

Mario
  • Posts: 1936


Return to Runtimes