MichelVictor

I am having a really bad time with mecanim and spine. I don't know if I am not working correctly or bugs.

For example if I select a clip and turn on "loop" sometimes it works, sometime not... sometimes I turn on and doesn't work at the beggining, but after sometime it suddenly start to work.

When I use Mecanim Override. Sometimes the animation doesn't even play, sometimes it plays normally, and sometimes play just the half of the animation.

Other thing I found that doesn't work as well, If I create for example an animation inside unity and put this clip together with other spine clips inside mecanim, the spine animations stop working.
For example I want to animate the material properties in a second add layer all spine animations stops.

I use mecanim with 3D and I never had this type of problem, there is a way to work with mecanim on spine or this are just bugs?

---

Any ideas?
MichelVictor
  • Posts: 73

Harald

We're very sorry that you are having troubles with Mecanim.
MichelVictor wrote:For example if I select a clip and turn on "loop" sometimes it works, sometime not... sometimes I turn on and doesn't work at the beggining, but after sometime it suddenly start to work.
Loop parameter not updating is a known bug and is tracked under this issue ticket:
https://github.com/EsotericSoftware/spine-runtimes/issues/1649

Problem:
When a Spine Mecanim animation clip's parameters like Loop Time are modified, the state in a Mecanim Controller is not automatically updated to reflect this change, it still has the old value stored.

Workaround until this issue is resolved:
With the Mecanim Controller active in the Animator window, select the non-updated state, change either it's Name or Tag (e.g. add a whitespace character and remove it later). This will update the state immediately and reload the clip's loop parameter.
Unfortunately we did not yet get to fix this issue, but it is in the queue for sure.
MichelVictor wrote:Other thing I found that doesn't work as well, If I create for example an animation inside unity and put this clip together with other spine clips inside mecanim, the spine animations stop working.
For example I want to animate the material properties in a second add layer all spine animations stops.
Thanks for reporting this issue, we have just committed a bugfix for it.
(issue ticket url for reference: [unity] SkeletonMecanim exception thrown at non-Spine clip · #1675)
A new 3.8 unitypackage is available can be downloaded here as usual:
Spine Unity Download
MichelVictor wrote:When I use Mecanim Override. Sometimes the animation doesn't even play, sometimes it plays normally, and sometimes play just the half of the animation.
By "use Mecanim Override" I assume you mean using a second layer with Blending set to Override, right?
I assume you are aware of that, but to be sure: Please note that only timelines which are keyed on the override track will be overridden.

Could you please send us a minimal reproduction Unity project that still shows the problems you are encountering, as a zip package to contact@esotericsoftware.com, we would be happy to fix these issues as well.

Thanks for reporting!
User avatar
Harald

Harri
  • Posts: 2091

MichelVictor

Hey there!
Thank you! The fix worked perfectly!
What a love about Spine is that everytime I have a issue you work it out!
It's the forth time you save my life haha!
---

Sorry, I meant Mecanim Animator Override Controller
https://docs.unity3d.com/Manual/AnimatorOverrideController.html

I can't use Animator Override Controller, the animations sometimes works, sometimes not.
MichelVictor
  • Posts: 73

Harald

MichelVictor wrote:Thank you! The fix worked perfectly!
What a love about Spine is that everytime I have a issue you work it out!
It's the forth time you save my life haha!
Didn't notice it's been the fourth issue already, but very glad we could resolve all your issues! :nerd:
So thanks for reporting and making Spine better every time! 8)
Sorry, I meant Mecanim Animator Override Controller
https://docs.unity3d.com/Manual/AnimatorOverrideController.html
I can't use Animator Override Controller, the animations sometimes works, sometimes not.
Oh, sorry. We will have a look at it and get back to you as soon as we've figured out what's going wrong there!
Thanks for reporting!

---

Unfortunately we could not reproduce the problem with the Mecanim Animator Override Controller. Could you please send us a minimal Unity reproduction project as a zip package that still shows the problem, to contact@esotericsoftware.com, then we can have a look at it.
User avatar
Harald

Harri
  • Posts: 2091

MichelVictor

Yes, I am the same guy from the joints 2D physics and the normalmap atlas package haha.

Thank you, if you have any news send me a private message please.
MichelVictor
  • Posts: 73

Harald

Harald wrote:Unfortunately we could not reproduce the problem with the Mecanim Animator Override Controller. Could you please send us a minimal Unity reproduction project as a zip package that still shows the problem, to contact@esotericsoftware.com, then we can have a look at it.
Did you send us a reproduction Unity project as requested above? I could not find any new email in the inbox or spam folder.

---

Harald wrote:Thank you, if you have any news send me a private message please.
In general we will always only reply to the forum thread, please note that you can subscribe to the topic to receive notifications.
User avatar
Harald

Harri
  • Posts: 2091

MichelVictor

Sorry about the delay, I just sent the email.
MichelVictor
  • Posts: 73

Harald

Thanks for sending the reproduction assets. At first we were tricked by the Player character also using the Player Override Controller (I guess this was a mistake). After replacing it with the main Player Mecanim Controller, we could reproduce the problems described in the email.

I've added remarks to this issue ticket here:
https://github.com/EsotericSoftware/spine-runtimes/issues/1649
We will post here on the forum as soon as we've come up with a bugfix.

---

The Material animation issue resolved as being a user error:

MecanimBlendAdditive_Color.png


This was due to the Mecanim layer of the Master Controller being set to Blending Additive instead of Override. Material-changing Animations are thus correctly applied (they were never in the hands of spine-unity anyway).

---

We can happily announce that the reported problems regarding Loop Time not being updated are now fixed. :cooldoge:

Updated 3.8 spine-unity unitypackages are available for download here as usual:
Spine Unity Download

Thanks for reporting!
You do not have the required permissions to view the files attached to this post.
User avatar
Harald

Harri
  • Posts: 2091


Return to Unity