Norsevidur

Hey. I have had this bug for a month and I cant figure out how to solve it.
Every time I launch Spine it just loads forever. The only temporary soloution ive found is to delete my Spine folder in C:\Users\Norsevidur\Spine.

This is pretty tedious to do every day and it resets all my application settings and recent projects. Been searching around, and it seems to be a very uncommon bug.

Please help.
Norsevidur
  • Posts: 16

Nate

Sorry you are having trouble. What shows in C:\Users\Norsevidur\Spine\spine.log, if anything? Can you try deleting the .json files from that folder, one at a time? It could help if we know which one helps when deleted.
User avatar
Nate

Nate
  • Posts: 9333

Norsevidur

No log file, but deleteting prefs.json lets me start Spine again. I dont mess with the preferences, usually I just enable autokey and change the background pattern. Thanks for the quick response :)
Norsevidur
  • Posts: 16

Nate

Hmm that's really odd. When Spine doesn't find a prefs.json file, it creates a new one with the defaults. Can you post or email your prefs.json that makes Spine hang? contact@esotericsoftware.com Another option is to delete half the name/value pairs in the file (leaving the } at the end of the file) until you don't get a hang, so we can see what exactly causes the hang (Spine should use the default values for missing values). It's a kind of JSON that isn't pretty printed, so may look a bit daunting. I can make a human readable version of your file after you send it.
User avatar
Nate

Nate
  • Posts: 9333

Norsevidur

Its seems it is the line "monitor:0" that prevents Spine from starting. That line gets created if I save the project while its open on my work monitor. I got a laptop with a connected 27" monitor.
Norsevidur
  • Posts: 16

Nate

Hmm, that is interesting. That value stores which monitor Spine was last run on, so next time it opens it will appear on the same monitor. It isn't clear yet why that would hang!

When there is no prefs.json file or when it doesn't have a monitor value, it uses the system's default monitor. That seems to work fine for you. When Spine closes, it records the index of the monitor it was on. Next time it runs it uses that monitor index to decide where to create the window. The index should match the same monitor, unless you swap monitors around while Spine is closed. It must be something about the monitor that is causing Spine to be unable to create the window. It would be much better if it would crash and print an error in the spine.log file, rather than hang.

Can you please try running Spine, putting it on one of your monitors, closing Spine, then running it again? Then repeat with the other monitor. The goal is to see if it works on one monitor but not the other. If it fails on both, you could try disconnecting the external monitor.

Are you running the latest graphics drivers for your laptop? That may help.
User avatar
Nate

Nate
  • Posts: 9333

Norsevidur

Its incredible how fast you answer, Nate. Spine got the best customer-support ive ever encountered!
If I open and then close Spine while its on the laptop monitor its no problems at all. Tried to do this like 5 times in a row without problems, but as soon as I move Spine over to the 2nd monitor it hangs on the next startup, every time. Ill try to update my VGA driver tomorrow when I have access to better internet and see if that helps!
Norsevidur
  • Posts: 16

Nate

Thanks, got to take care of our people! :)

OK, I'll be interested in whether driver update helps.
User avatar
Nate

Nate
  • Posts: 9333

Norsevidur

Sadly updating both VGA drivers didnt help. Did a clean install, but the problem persist :/
Norsevidur
  • Posts: 16

Nate

Hmm. Could it be that rather than hanging, Spine is opening somewhere off screen? Can you please try this: run Spine twice so it appears to hang the second time, hold shift and right click Spine in the Windows taskbar to get the old style Windows context menu, click Move, then press an arrow key on the keyboard. After that, when you move your mouse the Spine window will be stuck to the mouse cursor. Does the Spine window show up? If so, it was likely shown off screen for some reason.

Another thing to try is to maximize Spine, then close it. When it opens again it may be initially positioned off screen, but then should maximize to fill the screen.

If that seems to be the problem, could you please show a screenshot of the Windows multiple display settings? I'd like to see how the monitors are arranged so we can try to replicate the problem.
User avatar
Nate

Nate
  • Posts: 9333

Norsevidur

Tried what you suggested, but didnt make much progress. From what I can tell its not open off screen. It wont open, just stuck on starting Spine 3.8.76.
When I launch Spine the loader always opens on my laptop screen. Have attached a screenshot that shows what happens when I start Spine.

Display #1 is my laptop and #2 is my 27" monitor ( that causes the bug ). My monitors is set to expand between monitors. And the resolution is 1920x1080 on both monitors.
Norsevidur
  • Posts: 16

Nate

Thanks. I've saved locally and removed the attachment, since it showed your email.

We'll see if we can reproduce the problem with a similar setup. Unfortunately, it seems we don't have a solution right now. In 3.9, we've made it so you can set monitor: -1 in the prefs.json file and Spine will skip trying to open on a specific monitor. That is not a real fix, but at least removes some of the annoyance.

Sorry for the trouble!
User avatar
Nate

Nate
  • Posts: 9333

Norsevidur

Thank you very much, Nate :) Really appreciate the lenght you guys are going to provide good customer support :)
Norsevidur
  • Posts: 16


Return to Bugs