afasol

Hi there,

new to Spine, so apologies upfront in case I'm boring you with well-known topics - but I could not find yet an answer to this issue in the forums.

So, I have drawn a dummy sprite in Krita, something like 600 x 1900 px, then scaled it down to 25% (about 150 x 475 or so), using bicubic filter for resizing. Cut it in pieces, imported to Spine and made a very simple test animation. Watching it in Spine, it plays smooth and fine.

Then I have exported the animation (atlas is 512 x 256) and used it in gamemaker. There, the animation doesn’t look that smooth anymore; some lines are a bit clipped, and when animating they give some sort of wavy feeling.

Dummy animation Spine vs GM.png

(spine on the left, GM on the right)

Something wrong in exporting from Spine / importing to Gamemaker? I have tried playing with several parameters in the export panel (premultiply alpha on/off, bleed on/off, square atlas on/off), could not see any noticeable difference. On the Gamemaker side, I’ve tried matching the premult. alpha settings used in the Spine export, but not much more than that.

Any tips, or any specific information I should post?

Using Spine v3.7.94 and GM 2.3 by the way.
You do not have the required permissions to view the files attached to this post.
afasol
  • Posts: 2

Mario

Looks like GM is using nearest filtering for the images/textures instead of linear or bilinear filtering (which is what the Spine Editor uses unless told otherwise). I couldn't find GM docs on how to set the image/texture filters I'm afraid, but I'm sure they expose it somehow.
User avatar
Mario

Mario
  • Posts: 2404

afasol

Thanks Mario!

I've followed up on your tip, and managed to find a fix.

For the record, I've used the GM2 function gpu_set_tex_mip_filter(tf_anisotropic). There may be smarter ways do to that, but so far it looks like it's working
afasol
  • Posts: 2


Return to Editor