VadimM

hello
I got some issue with Skeleton Graphic Tint Black shader, i try many things to make it works correct, but still this purple color on my animation. Skeleton tint black shader with skeleton animation works fine and tint is correct, only when i use SkeletonGraphic (UnityUI) the tint is brocken.
I was hoping you could tell me how to fix it? What i'm doing wrong?
tint_black_problem.jpg


This how animation should look. (preview from spine)
box_lock.gif
You do not have the required permissions to view the files attached to this post.
User avatar
VadimM
  • Posts: 2

Harald

Unfortunately the image urls seem broken (at least they do not display anything for me, just the broken URL placeholders).

To be sure:
Did you assign a material with shader Spine/SkeletonGraphic Tint Black shader at a SkeletonGraphic component, right? If so, could you please send us a minimal reproduction Unity project that still shows the problem, as a zip package (not unitypackage) to contact@esotericsoftware.com. Then we can have a look at what's going wrong.
User avatar
Harald

Harri
  • Posts: 2091

VadimM

Sorry for broken URL (i fix it). Actually i found a solution, the problem with canvas additional shader channels, need to turn on TexCoord1, TexCoord 2, TexCoord 3.
User avatar
VadimM
  • Posts: 2

Harald

Thanks for updating the posting, glad you figured it out!
Actually you should be able to disable TexCoord3, as TexCoord1 and TexCoord2 should be sufficient.

For anyone having similar problems, the documentation page shows how to enable TexCoord1 and TexCoord2 channels:
spine-unity Runtime Documentation: Rendering
User avatar
Harald

Harri
  • Posts: 2091


Return to Unity