Health_Potion

I update both Spine and the Unity Spine run time. After doing so I have ~30 errors. Many of them occur some attachment script

"object' does not contain a definition for Value' and no extension method Value' of type object' could be found. Are you missing an assembly reference?"
The errors are all similar to this one. Some complain about no definition for .Key

I do not have more information because I freaked out and immediately reverted the project back to Spine 3.7. Knowing that this issue will occur, I'd be willing to update again to help find the issue.
Health_Potion
  • Posts: 3

Nate

Did you export your projects with Spine 3.8? Doing so is a requirement to use the 3.8 runtimes.
User avatar
Nate

Nate
  • Posts: 9161

Health_Potion

Yes, I updated the Unity Runtime first and then re exported my animation with spine 3.8.

Most of the errors seemed like a runtime issue as they came from Spine scripts.
Health_Potion
  • Posts: 3

Nate

Hmm, the errors really sound like a 3.8 runtime trying to load 3.7 JSON data. Could that be possible?
User avatar
Nate

Nate
  • Posts: 9161

Harald

It sounds to me like compile errors before any import takes place.

Can it be that you have extracted the Spine-Unity 3.8 runtime over the existing 3.7 runtime without deleting it beforehand? That would explain the errors. I will write a forum posting similar to Pharan's upgrade guide here to prevent some upgrade problems:
Spine-Unity 3.6 to 3.7 Upgrade Guide

Anyway, please re-download the unitypackage from the download page again, I have just fixed a different bug (related to import order that might cause error messages upon first package import):
Spine Unity Download

---

I have now created the respective 3.7 to 3.8 upgrade guide here:
Spine-Unity 3.7 to 3.8 Upgrade Guide
User avatar
Harald

Harri
  • Posts: 850


Return to Runtimes