pony

我遇到了和他同样的问题:http://zh.esotericsoftware.com/forum/Unity-Spine-Assetbundle-skeletonDataAsset-nul-12322
但是帖子后面你们改为私聊,我无法得知你们是如何帮他解决的该问题。

我的问题:
1(主要).我将spine资源打包为Assetbundle之后, SetToSetupPose() 报错:Object reference not set to an instance of an object
我使用了 Initialize(false) 这个API解决了这个问题,但这个API会引发掉帧等怪异的问题,我来这里是来寻求更好的办法。
2. 打包Assetbundle后,使用AnimationState.SetAnimation 切换动画时,贴图会缺失,比如五官的贴图消失了,如何解决?

软件版本:
unity:2017.4.3f1
spine:3.7.94
spine to unity(插件): spine-unity-3_7-2019-08-05

我已经将最小的工程案例发到你们的邮箱 contact@esotericsoftware.com,期待尽快解决
pony
  • Posts: 7

Harald

pony wrote:我遇到了和他同样的问题:http://zh.esotericsoftware.com/forum/Unity-Spine-Assetbundle-skeletonDataAsset-nul-12322
但是帖子后面你们改为私聊,我无法得知你们是如何帮他解决的该问题。
您发布的论坛网址已损坏。 无论如何,我都是通过搜索找到的,但是请务必粘贴有效的网址,以节省我们更多的时间来调查问题,而不是进行搜索。

The forum url you posted is broken. I found it via search anyway, but please be sure to paste working urls to save us more time for investigating the problem instead of searching.

关于另一线程上的解决方案:
解决方案是告诉用户他的复制项目太大,他应该创建一个最小的项目。 请求后,他回答说他解决了问题,没有告诉我们出什么问题了。 因此很遗憾,我们无法在论坛上分享解决方案。

Regarding the solution on the other thread:
The solution was to tell the user that his reproduction project is too large and he shall create a minimal project. After requesting it, he answered that he solved the problem, without telling us what was wrong. So unfortunately we could not share the solution on the forum.

感谢您发送复制包,一旦发现问题所在,我们将尽快与您联系。
Thanks for sending the reproduction package, we will get back to you as soon as we figured out what is going wrong.

---

1(主要).我将spine资源打包为Assetbundle之后, SetToSetupPose() 报错:Object reference not set to an instance of an object
我使用了 Initialize(false) 这个API解决了这个问题,但这个API会引发掉帧等怪异的问题,我来这里是来寻求更好的办法。
以后分配一个 SkeletonDataAsset 时需要调用 Initialize(false);。当我在你的复制项目test.cs文件中添加sg.Initialize(false);这一行时,一切都在我的电脑上正确加载和显示。我没有看到你所说的掉帧等问题。你说的到底是什么意思,你遇到了什么问题?

You need to call Initialize(false); when you assign a SkeletonDataAsset later. When I add the line sg.Initialize(false); at your reproduction project test.cs file, everything loads and displays correctly on my PC. I see no problem like dropped frames that you described. What exactly did you mean by that, what issues are you encountering?
2. 打包Assetbundle后,使用AnimationState.SetAnimation 切换动画时,贴图会缺失,比如五官的贴图消失了,如何解决?
在添加Initialize(false);调用后,我们无法重现您所描述的丢失图像的问题。无论是在Unity编辑器中,还是在构建成可执行文件时,一切都能正确显示。
After adding theInitialize(false); call, we could not reproduce the problem you described as missing images. Everything displayed correctly, both in the Unity Editor as well as when built to an executable.
User avatar
Harald

Harri
  • Posts: 2091


Return to 中国Spine用户