davidp

Hi,

I've been experiencing a weird issue where on some mobile android devices, SkeletonJson.readSkeletonJson() seems to hang and not let the program progress. Oddly, this happens only after one or two reloads, after it has previously loaded fine. This happens on multiple android devices (tested Samsung S8 to S10), unable to replicate this on PC or iPhone devices.

EDIT: Seems to be fixed in 3.8-beta
davidp
  • Posts: 4

badlogic

I assume there was a version mismatch between the Spine Editor version you exported from, and the Spine Runtimes version you used. At least that's what I take away from your other thread :)
User avatar
badlogic

Mario
  • Posts: 1936

davidp

badlogic wrote:I assume there was a version mismatch between the Spine Editor version you exported from, and the Spine Runtimes version you used. At least that's what I take away from your other thread :)
Don't think so :) Our QA team came back saying that it's still happening. It loads all the spines, then from that I create the SkeletonMesh's for each spine data, like so:
for (let i = 0; i < spines.length; i++) {
let atlas = common.assets.spineCache.get(`${spines[i]}.atlas`);
let loader = new spine.AtlasAttachmentLoader(atlas);
let json = new spine.SkeletonJson(loader);
this._skeletonData[spines[i]] = json.readSkeletonData(common.assets.spineCache.get(`${spines[i]}.json`)); // doesn't progress after this
this._spines[spines[i]] = new spine.threejs.SkeletonMesh(this._skeletonData[spines[i]]);
}
It always seems to hang after it has been previously loaded, after you refresh the page, at a frequency of about 3/5 times. No errors in the console. It always hangs at the first iteration of the loop. Spine version is 3.8.52-beta & runtime is latest 3.8-beta version from Github.
davidp
  • Posts: 4

badlogic

The code you posted looks fine. It's hard to tell what could cause this without being able to reproduce the issue locally. If you have a repro for me, I can try to figure out what's going on (though I don't have a Samsung S8 or S10 available).
User avatar
badlogic

Mario
  • Posts: 1936


Return to Runtimes