Eclair

我的团队原先在UE4.15上开发项目,现在准备升级引擎版本至4.22.3,之前合作的美工因个人原因离职,他使用spine 3.5.51c制作了大量素材。我尝试使用spine-ue4 3.5插件导入spine素材,但是运行库始终不能编译成功,我尝试使用了3.7、3.8运行库,可以正常编译但不能导入。于是我降低UE4版本至4.16、4.20但3.5运行库还是不能正常编译。
使用3.5运行库编译,错误是在RuntimeMeshComponent.build.cs RuntimeMeshComponentEditor.build.cs中使用了参数为0的构造函数。
我结合3.6运行库对应文件进行了部分代码修改,但出现大量的“__cplusplus”定义为预处理器宏,用“0”替换“#if/#elif”和找不到指定文件的错误。
我现在没有项目文件,只有.skel .altas和.png纹理文件,无法将其导入3.8版本。
请问,有办法在UE4.22.3上使用spine 3.5.51c导出的文件吗,或者请告知我3.5运行库实际支持的UE4版本。谢谢。
Eclair
  • Posts: 2

badlogic

恐怕无法使Spine 3.5运行时与高于4.16的任何UE版本一起使用。 API已更改。

请将旧的Spine 3.5项目转换为3.8,并在3.8版中使用Spine运行时。 如果您有原始的.spine项目文件,则只需将其加载到Spine Editor 3.8版中,然后重新导出。

I'm afraid there's no way to make the Spine 3.5 runtime work with any UE version higher than 4.16. The APIs have changed.

Please convert your old Spine 3.5 projects to 3.8 and use the Spine Runtimes with version 3.8. If you have the original .spine project files, you can just load them in Spine Editor version 3.8 and re-export.
User avatar
badlogic

Mario
  • Posts: 2168

Eclair

非常感谢您的回答
Eclair
  • Posts: 2


Return to 中国Spine用户